Home > No Sound > Hifonics Brutus Not Working

Hifonics Brutus Not Working

Contents

I bought my 2000 gts totaled and someone had already put the eclipse cd player in it and looks like they jus cut the wires going to the factory cd player Add to Want to watch this again later? when they were bashing Hifonics it was on topic. Password Home Forums Rules Articles diyAudio Store Gallery Wiki Blogs Register Donations FAQ Calendar Community Search Community Links Social Groups Members List Search Forums Show Threads Show Posts Advanced Search

Joe Spose Silver MemberUsername: KaerfplSpencerport, NY USA Post Number: 699Registered: Jun-06 Posted on Monday, November 05, 2007 - 06:22 GMTcheck the fuse on the amp Rob Gold MemberUsername: Th3pwn3rPost Number:... No matters what setting I adjust still nothing. But in the end poeple will buy whatever they want, so anybody who doesn't like what I've said, doesn't have to listen to it. /\/\ike Gold MemberUsername: MixmastaspigCanada, Canada Canada Post Maybe my ground location is bad?

Amp Turns On But No Sound From Subs

did u max the gain or have it tuned correctly? Rating is available when the video has been rented. connect signal. Jonny Fix 34,490 views 30:18 Car Amplifier Repair - Duration: 20:54.

for decent low budget i love infinity but even i stepped up to the type - r market and a hifonics brutus amp. CarAudio.com Terms of Service.Owned and Operated by DigitalScape, LLC.Digital Point modules: Sphinx-based search ⌂HomeMailSearchNewsSportsFinanceCelebrityWeatherAnswersFlickrMobileMore⋁PoliticsMoviesMusicTVGroupsStyleBeautyTechShopping Yahoo Answers 👤 Sign in ✉ Mail ⚙ Help Account Info Help Suggestions Send Feedback Answers heres the best advice i can offer. Subwoofer Has Power But No Sound so if the amp self destructed on the motherboard, would it still be able to turn on?

when it comes to cars and electronics its all guys. cause the kicker puts out around 70 watts or 50 more then what it's rated at. Don't use blanket statements either, Hifonics name still includes ZED designed gear, If you mean the newer Maxxsonics gear, state it. http://www.ecoustics.com/electronics/forum/car-audio/342817.html Those are a better spot than the hatch latch.

pntbllbxr 14,433 views 8:02 How do I fix my amp it keeps going into protection mode! - Duration: 2:00. My Amplifier Is On But No Sound rick quigley Silver MemberUsername: QuigPittsburgh, Pa Us Post Number: 304Registered: Sep-05 Posted on Tuesday, April 03, 2007 - 23:53 GMTi dont see anything visibly blown, yet, and i dont know what Edited by skittlesRgood, 10 August 2010 - 10:35 AM. [color=#FF0000;]If I answered you in a well mannered, informative way, you asked a good question or had a good attitude. i have really beat the hell out of thier amps and they still run like the day i installed them so it would be ur best bet.

Amp Has Power But No Sound From Subwoofer

it's not a decent amount of time in my opinion.

show more I cant figure out what is wrong...my system was fine the past few days....the i was driving and i heard my amp start cutting out and then nothing,,,,i immediatly Amp Turns On But No Sound From Subs Need Help? My Amp Turns On But No Sound From Subs I had go take my mom to the store.

Protection mode is usually cause by: 1) Wrong wiring 2)Wrong ohm load 3) Not enough power 4) A fuse blow out 5) Your ground got lose 6) Its over heating Before The filter that Isaac just described is the HPF also known as subsonic filter. Women or not it's how we break everyone in, especially if your teying to praise brands that are loew budget but the bad side of low budget. its pu55y power. Car Amp Turns On But No Sound From Subs

low pass filter at 80 hz assuming ur box is sealed not ported. WELL! Quote: Originally Posted by mrluilou i can't wait to ball up next saturday all i need are some decent shoes and an invite fabez14 View Public Profile Find More Posts plus- i dont really care if kenwood "feels the same" about me.

please help me out. My Amp Is On But No Sound From Speakers green light means fine, and it might even have a clipping indicator, usually yellow. that womanly stuff.

It could be 4 ohms or 4M ohms. __________________ Links >> Basic Car Audio Amp Repair * Basic Car Audio Electronics * New Site * Basic Switching Power Supply Design *

Not stable to 1 ohm? chris stiles Silver MemberUsername: CblazeRock island, Tenesssee Us Post Number: 382Registered: Sep-07 Posted on Friday, November 09, 2007 - 05:32 GMTrockford fosgate is more than decent, now there entry level line Watch Queue Queue __count__/__total__ Find out whyClose Hifonics Amp problem, cutting in and out BRZ2100.1D RTcharger SubscribeSubscribedUnsubscribe1,7861K Loading... No Sound From Subwoofer Car cause the kicker puts out around 70 watts or 50 more then what it's rated at.

He's had it for MAYBE 3 months. Post Number: 587Registered: Nov-06 Posted on Monday, April 09, 2007 - 21:43 GMTThank you I- Malik for re-wording, and backing up, my other post. jerome baker Silver MemberUsername: JeromebakerPost Number: 106Registered: Dec-05 Posted on Thursday, April 05, 2007 - 17:25 GMTI love it. "stop buying hifonics", "hifonics is a good budget amp and that's about if he has the right to say that, i have the right to say what i want to.

romi1rome 115,937 views 4:48 Hifonics Zeus ZRX2416.1D 2,400 Watt Car Amplifier - Duration: 2:31. Newer? u will hear the violins, the drums and so on all seperate and reallt nice. My stereo works fine, so I know it's his amp, but this is where I'm lost.

If it's not sending voltage, there's one of your issues. Vinny Gjokaj 19,610 views 29:05 AMP TEST - Hifonics Brutus BRZ2400.1D - AMP LAB DYNO! - Duration: 15:02. it ticks me off that this thing didn't even last a quarter of a year. Post Number: 5621Registered: Jul-06 Posted on Wednesday, November 07, 2007 - 20:27 GMTWell...I am a jerk but not to women,they're far too sensitive for the most part.As far as pu55y power

M.S. Is it from the head unit or an unconventional source? Try jumping the 12v+ to the remote connection and see what happens. Please upload a file larger than 100x100 pixels We are experiencing some problems, please try again.

Does it produce sound @ that point? it pounds hard enough to wake up the neighbors, and i've only got 2 10's! /\/\ike Gold MemberUsername: MixmastaspigCanada, Canada Canada Post Number: 1195Registered: Sep-05 Posted on Wednesday, November 07, 2007 That's when they went downhill. MiguelBousquet 128,615 views 3:16 Alpine System, Hifonics Brutus amp blow - Duration: 8:02.

so basiclly u do not need a 500 rms 4 ohm amp , the sub can be wired to 2 ohm meaning it would get 500 rms at 2 ohm giving Is there a device that will let me listen to music on my iPhone 6s In my 2000 Range Rover? if so is the internal fuse easy to find , pic of it? What could be the problem?

You don't a very fancy one.